1. Tämä sivusto käyttää evästeitä. Jatkamalla tämän sivuston käyttöä, annat suostumuksesi evästeiden käytöllemme. Lue lisää.

Linux + Nokia 6310i (IrDA) + DNA

Keskustelu osiossa 'Datatuotteet', aloittaja dokai, 5/8/02.

  1. dokai

    Liittynyt:
    5/8/02
    Viestit:
    1
    Tykkäykset:
    0
    Ongelmani on seuraavanlainen. IrDA toimii hyvin ja puhelimeen saa yhteyden, mutta ppp:tä en saa toimimaan. Connect scriptit näyttäisivät toimivan odotetun laisesti ja olen yrittäny monilla ei asetuksilla (mukaan lukien kaikki mitä tässä foorumissa on esitetty), mutta yhteyttä en saa toimimaan. Joko scripteillä tai manuaalisesti (minicom:lla) otettu homma toimii loistavasti soittoon asti, mutta sitten kun yhteys on saatu, niin toisesta päästä tulee jotain (binääri?) tavaraa ja homma tyssää siihen. Tässä esimerkki mitä minicom näyttää, kun yrittää:

    ATZ
    OK
    AT+CGDCONT=1,"IP","internet"
    OK
    ATDT*99#
    CONNECT
    ~ÿ}#.!}!} } }2}#}$.#}!}$}%Ü}"}&} }*} } g}%~~ÿ}#.!}!} } }2}#}$.#}!}$}%Ü}"}&} }*}

    Eli CONNECT:n jälkeen alkaa tulemaan tuota mössöä. Sama tulos tulee ppp-scripteilläkin. Onko jotain unohtunut. Jos jollain on toimiva Linux ja 6310i(IrDA) yhdistelmä niin kuulisin mielelläni kokemuksia. Oma distroni on Debian(unstable), joskin sillä tuskin merkitystä.

    t.kai hänninen
     
  2. mikael

    Liittynyt:
    16/8/02
    Viestit:
    1
    Tykkäykset:
    0
    Re: Sama ongelma Siemens M50

    Moi,

    Itse painin täsmälleen saman ongelman kanssa, eli serial yhteys toimii moitteetta puhelimeen saakka. Saan asetettua PDP-contexting ja aktivoitua PDP:n, mutta data-vaiheeseen siirryttäessä alkaa tulla kummaa dataa. Esim:

    AT+CGDCONT=1,"IP","internet"
    OK
    AT+CGQREQ=1,0,0,0,0,0
    OK
    AT+CGQMIN=1,0,0,0,0,0
    OK
    AT+CGATT=1
    OK
    AT+CGACT=1
    OK
    AT+CGDATA="PPP"
    CONNECT
    ~ÿ}#.!}!}#} }9}"}&} }*} } }'}"}(}"}%}&ùt..}#}%.#}%S.~~ÿ}#.!}!}#} }9}"}&} }*} } ~NO CARRIER

    Jos jollakin on ongelmaan ratkaisua, niin kuulisin mielelläni.
     
  3. vtormane

    vtormane Aktiivinen jäsen

    Liittynyt:
    19/6/02
    Viestit:
    4439
    Tykkäykset:
    0
    Re: Sama ongelma Siemens M50

    Surffatkaapa osoitteeseen: http://www.ee.oulu.fi/~mcfrisk/linux_gprs.html

    Itse sain ainakin Me45:sen toimimaan RH 7.1:ssä moitteettomasti, palveluna Dna Gprs.

    Kannattaa vaan lukea ohjeet hyvin ja edetä huolellisesti kohta kohdalta.

    Laittakaa sitten postauksia ihan mielenkiinnosta että saitteko toimimaan.
     

Jaa tämä viestiketju