1. Tämä sivusto käyttää evästeitä. Jatkamalla tämän sivuston käyttöä, annat suostumuksesi evästeiden käytöllemme. Lue lisää.

Linux ja GPRS (R600)

Keskustelu osiossa 'Datatuotteet', aloittaja taifu, 31/3/03.

  1. taifu

    Liittynyt:
    21/9/02
    Viestit:
    24
    Tykkäykset:
    0
    Voisiko joku kertoa yksityis kohtaisesti kuinka saan ericsson R600:n toimimaan linuxissa? Löysin netistä kyllä scriptit jo ja laitoin ne ohjeiden mukaan mutta ei pelaa. Windowssissa Puhelin toimii kyllä. Joten vika lienee linukan asetuksissa.
     
  2. tanheis

    Liittynyt:
    24/6/02
    Viestit:
    174
    Tykkäykset:
    0
    Anna meili osottees niin laitan tulemaan scripti filen jonka purat /et/ppp hakemistoon.
    Sitten ajat pppd file gprsr600 niin se yhdistää.
    Voit joutua lisäämään dna:n dns palvelimet /etc/resolv.conf tiedostoon
     
  3. taifu

    Liittynyt:
    21/9/02
    Viestit:
    24
    Tykkäykset:
    0
  4. tkorpela

    Liittynyt:
    24/6/02
    Viestit:
    120
    Tykkäykset:
    0
    Tältäkin foorumilta löytää paljon tietoa aiheesta. Hakutoiminto on ystäväsi.
     
  5. taifu

    Liittynyt:
    21/9/02
    Viestit:
    24
    Tykkäykset:
    0
    Hahaa sain propleeman ratkaistuksi. Vika olikin läppärin com portti asetuksissa. Elikkäs biossin puolella. Tässä TP 560 kun ei vaan pääse normaalisti biossista räpläämään vaan piti hommata ibm:n utility levy ja sitten conffaila :). Tein R600 asetukset wvdial.conf tiedostoon tuli paljon yksikertaisempi kuin nuo pppd:n kanssa suoraan käytetyt scriptit.
    Tässäpä vielä wvdial.conf tiedoston sisältä jos jotakuta kiinnostaa.

    [Dialer Defaults]
    Modem = /dev/ttyS1
    Baud = 115200
    #Init1 = ATZ
    #Init1 = AT+CGDCONT=1,"IP","internet"
    Dial Command = ATD

    [Modem0]
    Modem = /dev/ttyS1
    Baud = 115200
    Init1 = ATZ
    Init2 = AT+CGDCONT=1,"IP","internet",,0,0
    Init3 = AT+CGQREQ=1,0,0,0,0,0
    Init4 = AT+CGQMIN=1,0,0,0,0,0
    Init5 = AT+CGATT=1
    #SetVolume = 0
    Dial Command = ATD

    [Dialer gprs]
    #"Username = ""
    #Password = ""
    Phone = *99***1#
    Inherits = Modem0
    Stupid mode = 1
    Username = ""
    Password = ""
     
  6. hatu

    Liittynyt:
    4/4/03
    Viestit:
    3
    Tykkäykset:
    0
    Itselläni on Red Hat 9.0, R600 GPRS puhelin ja DNA liittymä, mutta en saa nettiä toimimaan. Sama ongelma kuin taifu:lla. Voisiko joku lähettää mullekin sen scriptin. Puhelin on liitetty tietsikkaan ericssonin sarjakaapelilla.

    e-mail: tuomas.haitto@jippii.fi
     
  7. taifu

    Liittynyt:
    21/9/02
    Viestit:
    24
    Tykkäykset:
    0
    Lisäys

    Jäi vielä kertomatta että myös /etc/ppp/peers kansiossa olevaan wvdial tidostoon täytyy lisätä tavaraa elikkäs se näyttää tältä.

    noauth
    debug
    local
    noipdefault
    ipcp-accept-local
    ipcp-accept-remote
    novj
    novjccomp
    noccp
    default-assyncmap
    nomagic
    defaultroute
    name wvdial
     
  8. hatu

    Liittynyt:
    4/4/03
    Viestit:
    3
    Tykkäykset:
    0
    Ei vieläkään yhteyttä R600:lla

    Mikä mahtaa olla vielä pielessä, koska wvdial:lla soitto pysähtyy lopussa olevaan Connect kohtaan. Wvdial tunnistaa puhelimen ajaa AT-komennot ja soittaa numeroon kuten pitääkin. Tarvitseeko wvdial.conf:iin määritellä vielä DSN-osoitteita vai osaako se hakea ne resolv.conf:sta ?
     
  9. tanheis

    Liittynyt:
    24/6/02
    Viestit:
    174
    Tykkäykset:
    0
    Re: Ei vieläkään yhteyttä R600:lla

    Mites pppd:n kanssa.. Saitko yhteyden toimimaan?
    Jos sait niin katso niitä scriptejä mitä wvdial scripteistä puuttuu.
    DNS osoitteet ainakin pppd hakee automaattisesti ja laittaa resolv.conf:iin

    Jollei muuten onnistu tee konsoli scripti joka ajaa pppd file scriptisi automaattisesti yhdellä käskyllä.
     
  10. taifu

    Liittynyt:
    21/9/02
    Viestit:
    24
    Tykkäykset:
    0
    wvdial:iin pitää myös muistaa conffata dns osoitteet
    Itse laitoin ne RH wvdial managerilla.
     
  11. flamingo

    Liittynyt:
    8/10/02
    Viestit:
    134
    Tykkäykset:
    0
    Mitä pitää kirjoitaa tiedostoon etc/localhost ? Nyt siellä lukee vain "localhost" ja kone herjaa aina kirjauduttaessa sisään että localhost on väärin.

    Sitten tuosta wvdial-jutusta...

    Olen nyt asettanut sekä /etc/wvdial.conf- ja /etc/ppp/peers/wvdial-tiedostojen sisällöt vastaamaan tässä ketjussa aiemmin annettuja.

    Nyt kun yritän ajaa wvdial niin tulee virheilmoitus:
    Configuration file does not provide a valid phone number
    Configuration file does not provide a valid user name
    Configuration file does not provide a valid password

    Ne ovat kuitenkin juuri samat kuin tässä ketjussa annetut.
    Lukeeko tämä wvdial näitä muuttujia nyt jostain toisesta paikasta vai miksi se tuolla tavalla herjaa?

    Puhelimeni on muuten R600 ja distro RedHat 9
     
  12. flamingo

    Liittynyt:
    8/10/02
    Viestit:
    134
    Tykkäykset:
    0
    Re: Lisäys

    Tämä on muuten hyvä, mutta tuo rivi default-assyncmap taitaa olla väärin. Itse kun korjasin sen muotoon defaulf-asyncamp niin johan alkoi yhteys pelittämään. Oli muuten erittäin pirullista löytää tuo syy, miksei yhteys toiminut.

    Pyytäisinkin, että jos täällä jotain scriptejä julkaistaan, niin vähintään pitäisi tarkistaa ettei niissä ole typoja. Kun Linux-keltanokat - niin kuin minä - alkavat niitä kokeilemaan, uskovat he skriptin toimivuuteen täysin, ja luulevat virheen piilevän heissä itsessään.
     
  13. (*.*)

    Liittynyt:
    10/1/03
    Viestit:
    102
    Tykkäykset:
    0
    Ei koodi toimi ei. oon kyl tehny nuitten ohjeitten mukaan, luulisin toimivan mut ei.

    Yritän yhistää(depug) tulee:
    ATDP *99***1#
    invalid dial command.
    wvdial.conf tiedostoon on laitettu asetukset miten pitääkin.
    miten se tuo linukka on et pitääkö se määritellä modeemi kuten winukasa vai jotenki muuten?
     

Jaa tämä viestiketju